FastReport使用交流,FastReport中国社区FastReport联系电话 联系电话:17347785263

报表工具FastReport VCL教程:在 Lazarus安装FastReport

来源:   发布时间:2021-03-31   浏览:次

FastReport VCL是用于Delphi,C ++ Builder,RAD Studio和Lazarus的报告和文档创建VCL库。它提供了可视化模板设计器,可以访问最受欢迎的数据源,报告引擎,预览,将过滤器导出为30多种格式,并可以部署到云,Web,电子邮件和打印中。

近日,FastReport VCL更新至v6.9,在新版本中,在PDF导出中增加了对以下对象的交互式表单支持:文本,复选框和图片。能够通过InteractiveFormsFontSubset属性将所需的字形仅包含在交互式形式中。同时修复了多个Bug问题。欢迎下载体验。(点击下方按钮下载)

立即点击下载FastReport VCL v6.9最新版

作为学院教育计划的一部分,我们决定为学生提供一些支持文章。

如果您要制作需要跨平台的业务或政府软件,或者仅在Linux系统或本机操作系统(也为Linux)上运行,最终将需要创建和输出电子文档,打印收据或某种格式(PDF ,office,HTML等)。而我们的FastReport VCL产品将很高兴为您提供所有这些帮助!

在 Lazarus安装FastReport

让我们从Lazarus的实际安装开始。
首先,我们需要为自己的操作系统安装该软件。

安装Windows的Lazarus

首先要做的是从官方网站下载Lazarus安装包 , 然后选择系统的位类型。

对于Windows,Lazarus安装程序是单个.exe文件,应该没有问题。

接下来,我们从官方网站 下载正确版本的档案 。

从下载的存档中将内容复制到C:Windows \ System32和C:Lazarus,然后重新启动Windows。启动Lazarus后,它会提示您立即进行配置。您只需要按OK并同意默认设置即可。 为Linux安装Lazarus

像在Windows中一样,您应该做的第一件事就是从官方网站 下载Lazarus安装程序包 。 

该列表中的每个项目均包含4个文件(3个安装程序包和一个文本文件)。

  • -Lazarus(项目)安装程序包;
  • -fpc-src安装程序包;
  • -fpc(laz)安装包;
  • -README.txt文件。

以正确的顺序安装它们很重要。首先是fpc(laz),然后是fpc-src,最后是Lazarus(项目)。

让我们事先解决字体问题。所有操作系统均具有默认设置的字体。例如,Arial是Windows和Ubuntu等默认字体。但是,Ubuntu中的默认Arial实际上与Windows中的Arial并不相同,这意味着使用Windows Lazarus进行的文本报告在Linux Lazarus中看起来很糟糕(反之亦然)。

为避免这种情况,我们至少要在Linux中安装与Windows相同的字体。

对于Ubuntu,您可以使用以下方法执行此操作:

sudo apt-get install msttcorefonts

但是对于其他Linux发行版,命令可能有所不同。

接下来,需要安装以下软件包才能使SqLite正常运行:sqlite3,libsqlite3-dev

更多详细信息可以在这里找到

对于Ubuntu,您可以使用以下方法执行此操作:

sudo apt-get install sqlite3 libsqlite3-dev

启动Lazarus,并在其中提示您进行配置。单击“确定”接受默认设置。

在Linux / Windows的Lazarus中安装FastReport软件包

我们已经安装了Lazarus,因此现在我们可以在Lazarus中安装FastReport VCL软件包。为此,我们需要从官方网站下载并解压缩该软件包。与Embarcadero Delphi,RAD Studio和C ++ Builder相比,仅“安装已编译的组件包”就足够了,而在Lazarus中,您必须对其进行编译。  要安装软件包,请单击软件包->打开软件包文件.lpk,在文件管理器中选择软件包,然后将出现以下屏幕:

在其中,单击“编译”,等待编译完成,然后单击“使用”。安装每个软件包后,Lazarus将重新启动。

继续执行FR软件包的安装顺序:

1. fast-script \ Source \ fs_lazarus.lpk –执行脚本的库;

2. fast-report-N \ Source \ frN_lazarus.lpk(法语)–包含所有必要组件的软件包;

3.以任何顺序:
-fast-report-N \ Source \ ExportPack \ frxeN_lazarus.lpk –带有出口的包装;
-fast-report-N \ Source \ lazchart \ frxchartlazarus.lpk –打包
图表;
-fast-report-N \ Source \ lazdbf \ frxlazdbf.lpk –用于处理BDF数据库的软件包;
-fast-report-N \ Source \ sqlite \ frxlazsqlite.lpk –用于SqLite基准数据库的软件包

在版本2.0.0之前,编译和/或安装错误非常普遍,在撰写本文时,最新版本是2.0.6,Lazarus中的此错误尚未完全消除,但发生的可能性要小得多。

如果您拥有不会编译/安装的软件包之一,则必须关闭并重新编译/重新安装软件包的依赖项。

为此,请双击它并重新编译,然后重新安装。

成功安装所有软件包后,单击项目->打开项目,然后打开fast-report-N \ LDemo \ FRDemo.lpi项目并尝试运行它,然后单击设计。

如果在Linux中收到此负高度错误:

那不用担心 关键是我们同时支持GTK和QT接口(但请记住,开发大部分是在GTK中完成的)。因此,在某些(很少见)GTK接口中,可以发现此错误。只需运行应用程序而无需调试,或选中“忽略此类异常”框。

*或更改您的图形外壳。例如,我们的许多团队都在GTK shell KDE Plasma下工作,而没有这种错误。

创建项目时,您应该知道的最后一件事是我们的设计器使用多线程,Linux Lazarus默认情况下将其禁用。为了打开它,请在Project Inspector(项目-> Project Inspector)中打开扩展名为“ .lpr”的文件,并在use单元cthreads中写入第一项。


还想要更多吗?您可以点击阅读【FastReport 报表2020最新资源盘点】,查找需要的教程资源。让人兴奋的是FastReport .NET正在慧都网火热销售中!在线订购惠享超低折扣。>>查看价格详情

本站文章除注明转载外,均为本站原创或翻译
欢迎任何形式的转载,但请务必注明出处,尊重他人劳动成果
转载请注明:文章转载自:FastReport控件中文网 [https://www.fastreportcn.com/]
本文地址:https://www.fastreportcn.com/post/2966.html

联系我们
  • 重庆总部 17347785263
购买
  • sales@evget.com
合作
  • business@evget.com


在线
客服
在线
QQ
电话
咨询
023-68661681
返回
顶部